Troubleshooting

Windows 8

  • The Erlang shell doesn't start on Windows 8 64bit
    Solution: You you have to install 64bit version of Erlang OTP.

Fedora

  • Which command should I run to install the package?
    Solution: rpm -i your_downloaded_erlang_rpm_package
  • When I run the installation, I have conflicting files.
    Solution: You already have an Erlang package installed. Run the following command sequence:
    • rpm -e your_old_package
    • rpm -i your_downloaded_erlang_rpm_package

CentOS

  • Which command should I run to install the package?
    Solution: rpm -i your_downloaded_erlang_rpm_package
  • When I run the installation, I have conflicting files.
    Solution: You already have an Erlang package installed. Run the following command sequence:
    • rpm -e your_old_package
    • rpm -i your_downloaded_erlang_rpm_package

Mac OS X

  • I cannot start any GUI erlang applications (including observer)
    Solution:The wx application is disabled in 64bit Erlang for Mac OS X. Please install 32 bit version.
  • I have Mac OS X Mountain Lion and I can't run the installer

    Solution: We are in a process of getting our package signed. Till then you should disable Gatekeeper functionality in order to install our package. The screenshot below shows the Security settings window with Gatekeeper turned off
  • I had an older version installed. After installing the new version, the old version of Erlang still starts.
    Solution: Remove the entire /usr/local/erlang/ folder, then run the installer again. If your previous version was in a custom location, remove that version's erlang folder, then run the installer again.

openSUSE

  • Which command should I run to install the package?
    Solution: rpm -i your_downloaded_erlang_rpm_package
  • When I run the installation, I have conflicting files.
    Solution: You already have an Erlang package installed. Run the following command sequence:
    • rpm -e your_old_package
    • rpm -i your_downloaded_erlang_rpm_package
  • When I run the installation, I have missing dependencies.
    Solution: Install the missing packages using either Yast or running rpm -i commands.
    For example, if the error message is the following:
       libwx_gtk2u_core-2.8.0.so.0 package is missing
    then select the following packages:
    • libwx_gtk2u_core-2_8-0-compat-lib-stl
    • libwx_gtk2u_core-2_8-0-stl

Ubuntu

  • Which command should I run to install the package?
    Solution: dpkg -i your_downloaded_erlang_deb_package
  • When I run the installation, I have conflicting files.
    Solution: You already have an Erlang package installed. Run the following command sequence:
    • dpkg -r your_old_package
    • dpkg -i your_downloaded_erlang_deb_package